Updated on: 06.Sept.2019

Requirements:
For Windows XP/Vista/7/8/8.1/10: NET Framework 3.5 - DOWNLOAD NOW


Note:
That's a zip files, which contains installation setup.



[ .ZIP ] MN Client 06.Sept.19 from MEGA






[ .ZIP ] MN Client 06.Sept.19 from GoogleDrive






[ .ZIP ] MN Client 15.Aug.19 from Torrent Tracker